Calls to our Contact Centre
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Jun 20, 2018 - 10:47 AEST
Identified
You might experience some issues getting in touch with us over the phone. However we're still here to help - please get in touch via chat, Facebook or e-mail while we are working through this issue.
Posted Jun 20, 2018 - 10:12 AEST