DVS All Docs
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Aug 01, 2021 - 10:29 AEST
Investigating
You will be unable to use our identity verification service when signing up to a plan. We understand this may be a little frustrating and appreciate your patience.
Posted Jul 31, 2021 - 17:00 AEST
This incident affected: Mobile.