Issues logging in or managing your account
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 17:39 AEDT
Investigating
We've identified an issue which means you might have some trouble logging in or managing your account on our website or via our app. Hang tight, we're working on the fix and we'll keep you updated.
Posted Feb 19, 2020 - 17:07 AEDT
This incident affected: Our website.