Unable to recharge/buy mobile products
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 23:16 AEST
Investigating
We're currently experiencing a small technical hiccup, which means you may experience issues when trying to make changes to your account. We appreciate your patience and recommend trying again through My amaysim in a few hours time
Posted Sep 17, 2019 - 22:03 AEST
This incident affected: Mobile.