Issues in Activating or Managing your Mobile Service
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 10:44 AEDT
Investigating
You might have some trouble managing your account using My amaysim, purchasing a SIM or activating a SIM. We're working on resolving the issue ASAP; we apologise for the inconvenience and thank you for your patience.
Posted Jan 24, 2020 - 08:25 AEDT
This incident affected: Mobile.