CSC unavailable
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 10:30 AEDT
Update
This issue is now resolved. Thanks for your patience.
Posted Nov 13, 2020 - 12:28 AEDT
Investigating
"We're seeing a high volume of calls, so getting through to us on the phone or chat might be difficult. However you can still get in contact with us via email (www.amaysim.com.au/help/contact) or there's a lot you can do in our mobile app."
Posted Nov 12, 2020 - 09:09 AEDT
This incident affected: Mobile.