Issues activating or modifying your mobile account

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted May 12, 2025 - 22:11 AEST

Investigating

We're currently experiencing an issue where you might have some trouble activating or making changes to your mobile service. We understand this may be a little frustrating and appreciate your patience.
Posted May 12, 2025 - 20:28 AEST
This incident affected: Mobile.