Remote Outage in Riverina region, NSW and North-East Victoria VIC 2644, 2642, 2640, 2660, 2641, 2658, 2659 3691

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Nov 16, 2025 - 10:25 AEDT

Investigating

The outage impacting amaysim customers in the Riverina region, NSW, and North-East Victoria, VIC, has been resolved and all services should now be back to normal.

If your service is still not working, please raise a fault.

Emergency Call service (000) status: fully operational.
Posted Nov 15, 2025 - 21:57 AEDT