Remote Outage in Far North, QLD

Incident Report for amaysim

Resolved

Amaysim can advise that the outage impacting customers in Far North QLD has been resolved and all services should now be back to normal. If your service is still not working, kindly raise a fault. We're sorry for the impact the outage had on our customers and thank them for their patience.
Posted Aug 24, 2025 - 23:02 AEST

Investigating

amaysim is aware of an outage affecting services for customers in Far North, QLD. The outage is impacting Mobile Voice and Mobile Data. The situation is being closely monitored, and efforts are underway to resolve the issue. We apologize for the inconvenience and appreciate your patience. At this time, the duration for resolution is unknown, but work is ongoing to fix the problem. Regular updates will be provided as more information becomes available.
Posted Aug 24, 2025 - 21:32 AEST