Activating or managing your mobile service
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Feb 24, 2024 - 23:55 AEDT
Update
We've identified an issue where you might have some trouble activating or making changes to your mobile service. We understand this may be a little frustrating and appreciate your patience.
Posted Feb 24, 2024 - 14:55 AEDT
Identified
We've identified an issue where you might have some trouble activating or making changes to your mobile service. We understand this may be a little frustrating and appreciate your patience.
Posted Feb 24, 2024 - 14:52 AEDT
This incident affected: Mobile.