Regional Outage in Snowy Mountains, NSW

Incident Report for amaysim

Resolved

We are pleased to advise that the outage impacting services in Snowy Mountains, NSW has been resolved and all services should now be back to normal.

The Emergency Call service (000) is operational.

If your service is still not working, please raise a fault.
Posted Nov 04, 2025 - 23:52 AEDT

Investigating

amaysim is aware of an outage affecting services:

Affected services: Mobile Voice and Mobile Data.
Affected area: Snowy Mountains, NSW.
Cause: Unplanned equipment failure.
Emergency Call Service (000): Coverage is lost due to this outage. Emergency service calls can be made where other mobile provider coverage is available or via WiFi.

Our teams are actively working to restore services as a priority. We will keep you informed of the progress.
Posted Nov 04, 2025 - 20:11 AEDT