Issues activating or managing your mobile or NBN service

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 01:40 AEDT

Investigating

You may encounter issues activating your SIM or NBN plan, logging into your account online or via the app, or managing your services. We're working to resolve this issue as quickly as possible and appreciate your patience.
Posted Feb 18, 2026 - 23:30 AEDT
This incident affected: Mobile and Home Internet.