Activating your mobile service
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Apr 07, 2024 - 13:10 AEST
Investigating
You may experience some issues with activating a SIM at the moment. We're working on resolving this ASAP. We apologise for any inconvenience and appreciate your patience.
Posted Apr 07, 2024 - 12:18 AEST
This incident affected: Mobile.