Interruption affecting Home Internet Service

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 09:33 AEDT

Identified

We've identified an issue with new broadband services in multiple locations. We're currently investigating this as a priority and will update this page when we know more.
Posted Dec 05, 2025 - 13:43 AEDT
This incident affected: Home Internet.