Activating or modifying your mobile account
Incident Report for amaysim
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 12:06 AEDT
Investigating
You might experience some trouble activating, or making changes to your mobile service. We understand this may be a little frustrating and appreciate your patience.
Posted Nov 19, 2024 - 11:15 AEDT
This incident affected: Mobile.