Delays in Completing Activation of New Home Internet Service

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted May 27, 2026 - 18:38 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 13:11 AEST

Identified

We're currently experiencing delays in completing activation for new NBN connections. Our team is actively working with the provider to resolve this as quickly as possible. We understand this may be a little frustrating and appreciate your patience.
Posted May 27, 2026 - 10:15 AEST
This incident affected: Home Internet.