Issues activating or managing your mobile service

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 00:45 AEDT

Identified

We've identified an issue where you might have some trouble activating or making changes to your mobile service. We understand this may be a little frustrating and appreciate your patience.
Posted Dec 17, 2025 - 19:38 AEDT
This incident affected: Mobile.