Regional outage in Geraldton area and surrounds, WA

Incident Report for amaysim

Resolved

amaysim can advise that the outage impacting our customers in Geraldton area and surrounds, WA has been resolved and all services should now be back to normal. If your service is still not working, kindly raise a fault.

Emergency Call service (000) status: The service is operational.
Posted Dec 15, 2025 - 05:59 AEDT

Update

amaysim is working on restoring an outage affecting services:

Affected services: Mobile – Voice & Internet.
Affected areas: Geraldton area and surrounds, WA.
Postcodes: 6528, 6530, 6535.
Cause: Multiple power outages due to storm in WA.
Emergency Call Service (000): Under investigation.
Our team is working on deploying generators, prioritising sites based on impact.

We appreciate your patience as we work to resolve the situation and will provide regular updates as more information becomes available.
Posted Dec 15, 2025 - 03:34 AEDT

Update

We are sorry that services are still impacted. There has been no new information since our last update.

Affected services: Mobile – Voice & Internet.
Affected areas: Geraldton area and surrounds, WA.
Postcodes: 6528, 6530, 6535.
Cause: Mass local power outage.
Emergency Call Service (000): Under investigation.

We apologise for the inconvenience this is causing and appreciate your patience.
Posted Dec 14, 2025 - 22:02 AEDT

Update

amaysim is aware of an outage affecting services. Further details below:

Affected services: Mobile – Voice and Internet.
Affected areas: Geraldton area and surrounds, WA.
Postcodes: 6528, 6530, 6535.
Cause: Mass local power outage.
Emergency Call Service (000): Under investigation.

Our teams are actively working to restore services as a priority. We will keep you informed of the progress. Thank you for your understanding.
Posted Dec 14, 2025 - 15:38 AEDT

Investigating

amaysim is aware of an outage affecting services:

Affected services: Mobile – Voice and Internet.
Affected areas: Geraldton area and surrounds, WA.
Postcodes: 6528, 6530, 6535.
Cause: Mass local power outage.
Emergency Call Service (000): Under investigation.

Our teams are actively working to restore services as a priority. We will keep you informed with the progress.
Posted Dec 14, 2025 - 15:24 AEDT