Perth Region, WA Severe Weather

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 06:22 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Dec 15, 2025 - 02:58 AEDT

Identified

Due to severe weather conditions in WA, some customers may be experiencing disruptions to their mobile and NBN services, voice calls, text and internet. We apologise for the inconvenience and thank you for your patience, our team is working to restore service as soon as it is safe to do so.

The next update is scheduled in 6 hours unless a significant development occurs sooner.
Posted Dec 15, 2025 - 00:58 AEDT
This incident affected: Mobile and Home Internet.