Regional Outage in Surf Coast - Bellarine Peninsula, VIC

Incident Report for amaysim

Resolved

Amaysim can advise that the outage impacting customers in Surf Coast - Bellarine Peninsula VIC has been resolved and all services should now be back to normal. If your service is still not working, kindly raise a fault. We're sorry for the impact the outage had on our customers and thank them for their patience.
Posted Aug 30, 2025 - 19:12 AEST

Investigating

amaysim is aware of an outage affecting services for customers in Surf Coast - Bellarine Peninsula, VIC due to power outages. The outage is impacting Mobile Voice and Mobile Data. We apologize for the inconvenience this is causing our customers. Our teams are working urgently to identify which services have been affected and to restore them as soon as possible. At this time, the duration of the resolution is unknown, but we are prioritizing resources to address the issue. We appreciate customers' patience as we work to resolve the situation and will provide regular updates as more information becomes available.
Posted Aug 30, 2025 - 18:02 AEST