Issues activating or modifying your mobile account

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 04:16 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 30, 2025 - 02:19 AEST

Investigating

You might have some trouble activating or managing your account using My amaysim or the amaysim apps. We're working on resolving the issue, apologies for the inconvenience and thanks for your patience.
Posted Jun 30, 2025 - 02:07 AEST
This incident affected: Mobile.