The outage impacting services in Alice Springs, NT has been resolved and all services should now be back to normal.
Emergency Call service (000) status: Please raise a fault if your service is still not working.
Posted Nov 08, 2025 - 17:52 AEDT
Update
There is an ongoing outage affecting services:
Affected services: Mobile Voice and Mobile Data. Affected area: Alice Springs, NT. Cause: Collaboration with an external provider to resolve the issue. Emergency Call Service (000): amaysim has loss of coverage due to this outage. Emergency calls can be made where other mobile provider coverage is available or via WiFi.
We are closely monitoring the situation and will keep you updated. Thank you for your patience.
Posted Nov 08, 2025 - 12:41 AEDT
Update
There is an ongoing outage affecting services:
Affected services: Mobile Voice and Mobile Data. Affected area: Alice Springs, NT. Cause: Collaboration with an external provider to resolve the issue. Emergency Call Service (000): amaysim has loss of coverage due to this outage. Emergency calls can be made where other mobile provider coverage is available or via WiFi.
We are monitoring the situation closely and will keep you updated. Thank you for your patience.
Posted Nov 08, 2025 - 06:52 AEDT
Update
There is an ongoing outage affecting services:
Affected services: Mobile Voice and Mobile Data. Affected area: Alice Springs, NT. Cause: Collaboration with an external provider to resolve the issue. Emergency Call Service (000): amaysim has loss of coverage due to this outage. Emergency calls can be made where other mobile provider coverage is available or via WiFi.
We are closely monitoring the situation and will keep you updated. Thank you for your patience.
Posted Nov 08, 2025 - 01:11 AEDT
Investigating
amaysim is aware of an outage affecting services:
Affected services: Mobile Voice and Mobile Data. Affected area: Alice Springs, NT. Cause: Collaboration with an external provider to resolve the issue. Emergency Call Service (000): amaysim has loss of coverage due to this outage. Emergency service calls can be accessed where other mobile provider coverage is available or via WiFi.
Our teams are actively working to restore services as a priority. We will keep you informed with the progress.