Network Outage Due to Cyclone/Tornado in Dowerin and Moora areas Western Australia

Incident Report for amaysim

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 14:04 AEST

Investigating

amaysim is aware of an outage affecting services:

Affected services: Mobile Voice and Mobile Data.
Affected area: Dowerin and Moora areas, Western Australia.
Cause: Natural event - Cyclone/Tornado.
Emergency Services: Coverage for emergency calls (000) is currently unavailable through amaysim. Emergency calls can be made where other mobile provider coverage exists or via WiFi.

Our teams are actively working to restore the services as a priority. We will keep you informed of the progress. We appreciate your understanding.
Posted Jun 01, 2026 - 00:53 AEST