Regional Outage in Snowy Mountains, NSW

Incident Report for amaysim

Resolved

The outage impacting services in Snowy Mountains, NSW has been resolved. All services should now be back to normal.

If your service is still not working, kindly raise a fault.

Thank you for your patience.
Posted Nov 04, 2025 - 15:12 AEDT

Investigating

amaysim is aware of an outage affecting services:

Affected services: Under investigation.
Affected area: Snowy Mountains, NSW.
Cause: Under investigation.
Emergency Call Service (000): amaysim has loss of coverage due to this outage. Emergency service calls can be accessed where other mobile provider coverage is available or can be made via WiFi.

Our teams are actively working to restore services as a priority. We will keep you informed with the progress.
Posted Nov 04, 2025 - 11:32 AEDT